设为首页收藏本站

ZMX - IT技术交流论坛 - 无限Perfect,追求梦想 - itzmx.com

 找回密码
 注册论坛

QQ登录

只需一步,快速开始

新浪微博账号登陆

只需一步,快速开始

用百度帐号登录

只需两步,快速登录

搜索
查看: 128|回复: 1

qBittorrent打开https无法进入WebUI的解决方法

[复制链接]

签到天数: 87 天

[LV.6]常住居民II

发表于 2024/7/7 09:12 | 显示全部楼层 |阅读模式 |Google Chrome 126.0.0.0|Windows 10
天涯海角搜一下: 百度 谷歌 360 搜狗 有道 雅虎 必应 即刻
本人没有代码基础,用的设备是刷了casaos的玩客云,由于是32位的arm处理器所以用的qb docker镜像是4.3.9的老版本
这一版本不会验证https的证书和密钥是否填写,只要勾上启动https再点保存直接就会启用https

图1

图1


访问webui会变成无图标纯文本的页面

unknown_2024.07.07-08.34.png

解决方法很简单

先关闭qb的docker 可以用命令 也可以在casaos页面qb图标右上角三个点关闭
再用winscp或其他软件搜索qBittorrent.conf找到qb的配置文件

图3

图3


casaos在配置页面也能看到配置文件(图4)

图4

图4


之后就是打开qBittorrent.conf
修改WebUI\HTTPS\Enabled
  1. WebUI\HTTPS\Enabled=false
复制代码


最后再重新打开docker就解决了 方法同上
[发帖际遇]: wudixxz 乐于助人,奖励 3 贡献. 幸运榜 / 衰神榜
欢迎光临IT技术交流论坛:http://bbs.itzmx.com/
回复

使用道具 举报

 成长值: 66

签到天数: 4579 天

[LV.Master]伴坛终老

发表于 2024/7/7 09:20 | 显示全部楼层 |Google Chrome 126.0.0.0|Windows 10
原创教程,支持,从配置文件里关闭https是一种很好的解决办法
欢迎光临IT技术交流论坛:http://bbs.itzmx.com/
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册论坛 新浪微博账号登陆用百度帐号登录

本版积分规则

手机版|Archiver|Mail me|网站地图|IT技术交流论坛 ( 闽ICP备13013206号-7 )

GMT+8, 2024/7/18 16:50 , Processed in 0.168023 second(s), 21 queries , MemCache On.

Powered by itzmx! X3.4

© 2011- sakura

快速回复 返回顶部 返回列表