设为首页收藏本站

ZMX - IT技术交流论坛 - 无限Perfect,追求梦想 - itzmx.com

 找回密码
 注册论坛

QQ登录

只需一步,快速开始

新浪微博账号登陆

只需一步,快速开始

用百度帐号登录

只需两步,快速登录

搜索
查看: 204|回复: 1

Linux centos 7 vps服务器安装系统后预留的那个内存叫什么啊,2G只有1800M可用,关闭KDUMP功能

[复制链接]
 成长值: 26705

签到天数: 3388 天

[LV.Master]伴坛终老

发表于 2021/1/28 00:44 | 显示全部楼层 |阅读模式 |Google Chrome 88.0.4324.104|Windows 10
天涯海角搜一下: 百度 谷歌 360 搜狗 有道 雅虎 必应 即刻
Linux centos 7 vps服务器安装系统后预留的那个内存叫什么啊,2G只有1800M可用,关闭KDUMP功能

安装后不是有个选项,默认是勾选的,就那个引起的。
安装时候不勾上就可以显示完整的2048M内存可用

通过安装虚拟机,,然后,就找到了,叫KDUMP
1.jpg

那么方法就有了,百度搜索如何关闭KDUMP就行了,不然如上图,分配1G,就只剩下800多M可用了

问题图如下
1.png

网上有些人说,ulimit -c 0不就好了,我想了下,感觉不对,这是是禁用错误报告吧。。控制输出core崩溃文件的大小值,而不是关闭KDUMP这个功能,内存是释放不出来的
2.png


好了,这里是真正的解决办法:
查看底层硬件信息,可以看到这台 2G 内存的服务器是分配足了 2048M 内存的。
可以看到输出信息被Reserving吞了161MB物理内存。
  1. dmidecode |egrep "Maximum|Size"
复制代码
        Runtime Size: 96 kB
        ROM Size: 64 kB
        Maximum Capacity: 2 GB
        Size: 2048 MB
        Maximum Voltage: Unknown
        Range Size: 2 GB
  1. dmesg | grep -i memory
复制代码
[    0.000000] Base memory trampoline at [ffff882680099000] 99000 size 24576
[    0.000000] Reserving 161MB of memory at 688MB for crashkernel (System RAM: 2047MB)
[    0.000000] Early memory node ranges
[    0.000000] PM: Registered nosave memory: [mem 0x0009f000-0x0009ffff]
[    0.000000] PM: Registered nosave memory: [mem 0x000a0000-0x000effff]
[    0.000000] PM: Registered nosave memory: [mem 0x000f0000-0x000fffff]
[    0.000000] Memory: 1861024k/2097008k available (7664k kernel code, 392k absent, 235592k reserved, 6055k data, 1876k init)
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.049787] Initializing cgroup subsys memory
[    0.362676] Freeing initrd memory: 18176k freed
[    0.383614] Non-volatile memory driver v1.3
[    0.383701] crash memory driver: version 1.1
[    0.406091] Freeing unused kernel memory: 1876k freed
[    0.407174] Freeing unused kernel memory: 516k freed
[    0.408306] Freeing unused kernel memory: 600k freed
[    0.918587] [TTM] Zone  kernel: Available graphics memory: 941110 kiB

停止并且关闭自启动
  1. systemctl stop kdump.service;systemctl disable kdump.service
复制代码

修改grub文件
将crashkernel=auto修改为crashkernel=0
  1. vi /etc/default/grub
复制代码
  1. GRUB_TIMEOUT=5
  2. GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
  3. GRUB_DEFAULT=saved
  4. GRUB_DISABLE_SUBMENU=true
  5. GRUB_TERMINAL_OUTPUT="console"
  6. GRUB_CMDLINE_LINUX="consoleblank=0 crashkernel=0 rhgb quiet"
  7. GRUB_DISABLE_RECOVERY="true"
复制代码

生成配置并重启
重启前注意无其他正在进行的工作,以免造成数据丢失
  1. grub2-mkconfig -o /boot/grub2/grub.cfg
  2. reboot
复制代码

通过free -m验证,成功解决问题



centos 6同理,关闭自启动
  1. chkconfig kdump off;service kdump stop
复制代码

可能跳出提示Please reserve memory by passing "crashkernel=X@Y" parameter to the kernel
感觉忽略就行,然后修改引导文件重启就好
引导文件在这,将crashkernel=auto修改为crashkernel=0
  1. vi /boot/grub/grub.conf
复制代码

重启前489M内存可用,重启后还是489M可用,,,不对劲
查了下,,原来centos 6是8G或者以上内存,才会执行这个Reserving操作
并且内存消耗好像是在free -m里面不会降低最大可用大小,通过上面的dmesg | grep -i memory命令可以查到有没有Reserving信息

[发帖际遇]: 小樱 乐于助人,奖励 2 贡献. 幸运榜 / 衰神榜
欢迎光临IT技术交流论坛:http://bbs.itzmx.com/
回复

使用道具 举报

签到天数: 972 天

[LV.10]以坛为家III

发表于 2021/1/30 01:10 | 显示全部楼层 |Google Chrome 88.0.4324.104|Windows 10
欢迎光临IT技术交流论坛:http://bbs.itzmx.com/
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册论坛 新浪微博账号登陆用百度帐号登录

本版积分规则

手机版|Archiver|Mail me|网站地图|IT技术交流论坛 ( 闽ICP备13013206号-7 )

GMT+8, 2021/4/13 02:37 , Processed in 0.177650 second(s), 22 queries , MemCache On.

Powered by itzmx! X3.4

© 2011- sakura

快速回复 返回顶部 返回列表