设为首页收藏本站

 找回密码
 注册论坛

QQ登录

只需一步,快速开始

用百度帐号登录

只需两步,快速登录

新浪微博账号登陆

只需一步,快速开始

搜索
查看: 283|回复: 0

linux升级Python 2.7.14后pip功能报错的解决方法

[复制链接]

签到天数: 2477 天

[LV.Master]伴坛终老

 成长值: 22125
发表于 2018/3/20 06:14 | 显示全部楼层 |阅读模式 |Google Chrome 65.0.3325.146|Windows 10
天涯海角搜一下: 百度 谷歌 360 搜狗 有道 雅虎 必应 即刻
Could not find a version that satisfies the requirement tempora==1.8 (from flexget) (from versions: 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.6.1)
No matching distribution found for tempora==1.8 (from flexget)
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6

[root@207 ~]# pip -V
pip 9.0.2 from /usr/lib/python2.6/site-packages (python 2.6)
[root@207 ~]# python -V
Python 2.7.14

大概,,问题应该是pip用了2.6的,和2.7的不通用导致的一个问题
试过pip install --upgrade pip也没有用

折腾了一下又出现一个新的错误
[root@207 ~]# pip install --upgrade pip
Traceback (most recent call last):
  File "/usr/bin/pip", line 7, in <module>
    from pip import main
ImportError: No module named pip
[root@207 ~]#


解决方案
  1. wget https://bootstrap.pypa.io/get-pip.py
  2. python get-pip.py
  3. mv /usr/bin/pip /usr/bin/pip.bak
  4. ln -s /usr/local/bin/pip2.7 /usr/bin/pip
复制代码


再次打印
[root@207 ~]# pip -V
pip 9.0.2 from /usr/local/lib/python2.7/site-packages (python 2.7)
[root@207 ~]#

已经成功切换到了2.7版本的pip,测试,pip的各种使用问题成功解决


参考官网:https://pip.pypa.io/en/stable/in ... ing-with-get-pip-py

[发帖际遇]: 小樱 乐于助人,奖励 7 贡献. 幸运榜 / 衰神榜
欢迎光临IT技术交流论坛:http://bbs.itzmx.com/
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册论坛 用百度帐号登录新浪微博账号登陆

本版积分规则

手机版|Archiver|Mail me|网站地图|IT技术交流论坛 ( 闽ICP备13013206号-7 )

GMT+8, 2018/10/15 23:36 , Processed in 0.243723 second(s), 41 queries , Gzip On, Memcache On.

Powered by itzmx!

© 2011-2018 sakura

快速回复 返回顶部 返回列表